Requirements

Updated 7 months ago by admin

Supported operating systems

Windows 11, Windows 10, Windows 8.1

32-bit or 64-bit

Windows 8.1 requires the KB2999226 patch
Device Guard is not currently supported on Server or Enterprise editions. Please contact Technical Support for more information.

Windows Server 2019, 2016, 2012, 2008r2

Windows Server 2008r2 requires this security update

Older versions

Please note that Windows XP and Windows Vista are not supported. For these operating systems, the USS Gateway agent is recommended. Windows 7 is supported in versions of the agent below 4.3.27.

Minimum system requirements

Dual core CPU, 2GB RAM

Network Control Ports and Firewall Exclusions

Ports 80 and 443 or 1344 and 1345 must be open in the outbound direction for the USS Agent to operate correctly.

Ports can be restricted to the hostname icap.clouduss.com if required.

Please note: this hostname has multiple IP addresses and all should be added to your firewall if domain based matching is not available.
Please note: even when the agent is disabled it will periodically connect to all the nodes in the assigned region. This is to ensure that the best node is selected when the agent is started again.

Web Browser Support

Please note that Internet Explorer 10 and below are not supported.


How did we do?